re = /^(?=.*[a-z])(?!.*[<>\\'"])[\x00-\x7F]{5,22}$/mi
str = 'ылшщъьбe
12345678901234567s9012
12345678901234567s90123
12345678901234567s901Я
abcdeabcdeab"abcde
abcdeabcdeab\'abcde
abcdeabcdeab\\abcde
abcdeabcdeab>abcde
abcdeabcdeab<abcde
abcdeabcdeab"abcde
abcdeabcdeababcde
12345678901234567s9012
12345678901234567s90123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end