use strict;
my $str = 'ылшщъьбe
12345678901234567s9012
12345678901234567s90123
12345678901234567s901Я
abcdeabcdeab"abcde
abcdeabcdeab\'abcde
abcdeabcdeab\\abcde
abcdeabcdeab>abcde
abcdeabcdeab<abcde
abcdeabcdeab"abcde
abcdeabcdeababcde
12345678901234567s9012
12345678901234567s90123';
my $regex = qr/^(?=.*[a-z])(?!.*[<>\\'"])[\x00-\x7F]{5,22}$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}