import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[a-z])(?!.*[<>\\\\'\"])[\\x00-\\x7F]{5,22}$";
final String string = "ылшщъьбe\n"
+ "12345678901234567s9012\n"
+ "12345678901234567s90123\n"
+ "12345678901234567s901Я\n"
+ "abcdeabcdeab\"abcde\n"
+ "abcdeabcdeab'abcde\n"
+ "abcdeabcdeab\\abcde\n"
+ "abcdeabcdeab>abcde\n"
+ "abcdeabcdeab<abcde\n"
+ "abcdeabcdeab\"abcde\n"
+ "abcdeabcdeababcde\n"
+ "12345678901234567s9012\n"
+ "12345678901234567s90123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}