import Foundation
let pattern = #"^(?=.*[a-z])(?!.*[<>\\'"])[\x00-\x7F]{5,22}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
ылшщъьбe
12345678901234567s9012
12345678901234567s90123
12345678901234567s901Я
abcdeabcdeab"abcde
abcdeabcdeab'abcde
abcdeabcdeab\abcde
abcdeabcdeab>abcde
abcdeabcdeab<abcde
abcdeabcdeab"abcde
abcdeabcdeababcde
12345678901234567s9012
12345678901234567s90123
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)