$re = '/^(?=.*[a-z])(?!.*[<>\\\\\'"])[\x00-\x7F]{5,22}$/mi';
$str = 'ылшщъьбe
12345678901234567s9012
12345678901234567s90123
12345678901234567s901Я
abcdeabcdeab"abcde
abcdeabcdeab\'abcde
abcdeabcdeab\\abcde
abcdeabcdeab>abcde
abcdeabcdeab<abcde
abcdeabcdeab"abcde
abcdeabcdeababcde
12345678901234567s9012
12345678901234567s90123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);