const regex = /^(?=.*[a-z])(?!.*[<>\\'"])[\x00-\x7F]{5,22}$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*[a-z])(?!.*[<>\\\\\'"])[\\x00-\\x7F]{5,22}$', 'gmi')
const str = `ылшщъьбe
12345678901234567s9012
12345678901234567s90123
12345678901234567s901Я
abcdeabcdeab"abcde
abcdeabcdeab'abcde
abcdeabcdeab\\abcde
abcdeabcdeab>abcde
abcdeabcdeab<abcde
abcdeabcdeab"abcde
abcdeabcdeababcde
12345678901234567s9012
12345678901234567s90123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}