# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=.*[a-z])(?!.*[<>\\'\"])[\x00-\x7F]{5,22}$"
test_str = ("ылшщъьбe\n"
"12345678901234567s9012\n"
"12345678901234567s90123\n"
"12345678901234567s901Я\n"
"abcdeabcdeab\"abcde\n"
"abcdeabcdeab'abcde\n"
"abcdeabcdeab\\abcde\n"
"abcdeabcdeab>abcde\n"
"abcdeabcdeab<abcde\n"
"abcdeabcdeab\"abcde\n"
"abcdeabcdeababcde\n"
"12345678901234567s9012\n"
"12345678901234567s90123")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.