# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?<start>[^0-9]+)?(?:[0-9]+)?(?<end>[^0-9]+)$/$1$2/gm;t' <<< "/dev/server/3/statistics
"