using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<start>[^0-9]+)?(?:[0-9]+)?(?<end>[^0-9]+)$";
string substitution = @"$1$2";
string input = @"/dev/server/3/statistics
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}