// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<start>[^0-9]+)?(?:[0-9]+)?(?<end>[^0-9]+)$").unwrap();
let string = "/dev/server/3/statistics
";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}