const regex = /^(?<start>[^0-9]+)?(?:[0-9]+)?(?<end>[^0-9]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<start>[^0-9]+)?(?:[0-9]+)?(?<end>[^0-9]+)$', 'gm')
const str = `/dev/server/3/statistics
`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);