re = /^(?<start>[^0-9]+)?(?:[0-9]+)?(?<end>[^0-9]+)$/m
str = '/dev/server/3/statistics
'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result