use strict;
my $str = '/dev/server/3/statistics
';
my $regex = qr/^(?<start>[^0-9]+)?(?:[0-9]+)?(?<end>[^0-9]+)$/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";