$re = '/^(?<start>[^0-9]+)?(?:[0-9]+)?(?<end>[^0-9]+)$/m';
$str = '/dev/server/3/statistics
';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;