# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=^(?: {4})*) {4}/\t/gm;t' <<< "
a = 1
aaaaaaa = 2
aaaa = 3
a = 1
aaaaaaa = 2
aaaa = 3"