#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=^(?: {4})*) {4}"
Local $sString = "" & @CRLF & _
" a = 1" & @CRLF & _
" aaaaaaa = 2" & @CRLF & _
" aaaa = 3" & @CRLF & _
" a = 1" & @CRLF & _
" aaaaaaa = 2" & @CRLF & _
" aaaa = 3"
Local $sSubst = "\t"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)