import re
regex = re.compile(r"(?<=^(?: {4})*) {4}", flags=re.MULTILINE)
test_str = ("\n"
" a = 1\n"
" aaaaaaa = 2\n"
" aaaa = 3\n"
" a = 1\n"
" aaaaaaa = 2\n"
" aaaa = 3")
subst = "\\t"
result = regex.sub(subst, test_str)
if result:
print(result)