using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^(?: {4})*) {4}";
string substitution = @"\t";
string input = @"
a = 1
aaaaaaa = 2
aaaa = 3
a = 1
aaaaaaa = 2
aaaa = 3";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}