const regex = /(?<=^(?: {4})*) {4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^(?: {4})*) {4}', 'gm')
const str = `
a = 1
aaaaaaa = 2
aaaa = 3
a = 1
aaaaaaa = 2
aaaa = 3`;
const subst = `\t`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);