use strict;
my $str = '
a = 1
aaaaaaa = 2
aaaa = 3
a = 1
aaaaaaa = 2
aaaa = 3';
my $regex = qr/(?<=^(?: {4})*) {4}/mp;
my $subst = '\\t';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";