# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:(\.\d*?[1-9]+)|\.)0*$/$1/gm;t' <<< "21250000.022000
20.00
20.50
20.0505
200.
1.010
.009870000
20
.0125"