$re = '/(?:(\.\d*?[1-9]+)|\.)0*$/m';
$str = '21250000.022000
20.00
20.50
20.0505
200.
1.010
.009870000
20
.0125';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;