const regex = /(?:(\.\d*?[1-9]+)|\.)0*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(\\.\\d*?[1-9]+)|\\.)0*$', 'gm')
const str = `21250000.022000
20.00
20.50
20.0505
200.
1.010
.009870000
20
.0125`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);