re = /(?:(\.\d*?[1-9]+)|\.)0*$/m
str = '21250000.022000
20.00
20.50
20.0505
200.
1.010
.009870000
20
.0125'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result