import re
regex = re.compile(r"(?:(\.\d*?[1-9]+)|\.)0*$", flags=re.MULTILINE)
test_str = ("21250000.022000\n"
"20.00\n"
"20.50\n"
"20.0505\n"
"200.\n"
"1.010\n"
".009870000\n"
"20\n"
".0125")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)