import Foundation
let pattern = #"(?:(\.\d*?[1-9]+)|\.)0*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
21250000.022000
20.00
20.50
20.0505
200.
1.010
.009870000
20
.0125
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)