#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "({%\sfor\s)([^{]|{(?!%\s(?:end)?for\s)|(?1)(?2)*(?3))*?customfield(?2)*({%\sendfor\s%})"
Local $sString = "as;flkjas;dflj sa;dfkj;s afdjk " & @CRLF & _
"{% for some in some%}" & @CRLF & _
" lj;lkj;lkj;ljk" & @CRLF & _
"{% endfor%}" & @CRLF & _
"{% for pepe in pepito %}" & @CRLF & _
" ;aldjkf ;ajkdf;ak " & @CRLF & _
" jfd;kajd;fjkasd;f" & @CRLF & _
"" & @CRLF & _
" {% for pepe in pepito %}" & @CRLF & _
" customfield" & @CRLF & _
" ;aldjkf ;ajkdf;ak " & @CRLF & _
" asdfsadf asdf sadf asdf asdfasd " & @CRLF & _
" jfd;kajd;fjkasd;f" & @CRLF & _
" {% endfor %}" & @CRLF & _
"" & @CRLF & _
" customfield" & @CRLF & _
"" & @CRLF & _
" asdfasdf" & @CRLF & _
" asdfasdf" & @CRLF & _
"{% endfor %}" & @CRLF & _
"sadfasdf" & @CRLF & _
"sadf" & @CRLF & _
"{% endfor %}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")