import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\{%\\sfor\\s)([^\\{]|\\{(?!%\\s(?:end)?for\\s)|(?1)(?2)*(?3))*?customfield(?2)*(\\{%\\sendfor\\s%\\})";
final String string = "as;flkjas;dflj sa;dfkj;s afdjk \n"
+ "{% for some in some%}\n"
+ " lj;lkj;lkj;ljk\n"
+ "{% endfor%}\n"
+ "{% for pepe in pepito %}\n"
+ " ;aldjkf ;ajkdf;ak \n"
+ " jfd;kajd;fjkasd;f\n\n"
+ " {% for pepe in pepito %}\n"
+ " customfield\n"
+ " ;aldjkf ;ajkdf;ak \n"
+ " asdfsadf asdf sadf asdf asdfasd \n"
+ " jfd;kajd;fjkasd;f\n"
+ " {% endfor %}\n\n"
+ " customfield\n\n"
+ " asdfasdf\n"
+ " asdfasdf\n"
+ "{% endfor %}\n"
+ "sadfasdf\n"
+ "sadf\n"
+ "{% endfor %}\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}