re = /({%\sfor\s)([^{]|{(?!%\s(?:end)?for\s)|(?1)(?2)*(?3))*?customfield(?2)*({%\sendfor\s%})/
str = 'as;flkjas;dflj sa;dfkj;s afdjk
{% for some in some%}
lj;lkj;lkj;ljk
{% endfor%}
{% for pepe in pepito %}
;aldjkf ;ajkdf;ak
jfd;kajd;fjkasd;f
{% for pepe in pepito %}
customfield
;aldjkf ;ajkdf;ak
asdfsadf asdf sadf asdf asdfasd
jfd;kajd;fjkasd;f
{% endfor %}
customfield
asdfasdf
asdfasdf
{% endfor %}
sadfasdf
sadf
{% endfor %}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end