use strict;
my $str = 'as;flkjas;dflj sa;dfkj;s afdjk
{% for some in some%}
lj;lkj;lkj;ljk
{% endfor%}
{% for pepe in pepito %}
;aldjkf ;ajkdf;ak
jfd;kajd;fjkasd;f
{% for pepe in pepito %}
customfield
;aldjkf ;ajkdf;ak
asdfsadf asdf sadf asdf asdfasd
jfd;kajd;fjkasd;f
{% endfor %}
customfield
asdfasdf
asdfasdf
{% endfor %}
sadfasdf
sadf
{% endfor %}
';
my $regex = qr/({%\sfor\s)([^{]|{(?!%\s(?:end)?for\s)|(?1)(?2)*(?3))*?customfield(?2)*({%\sendfor\s%})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}