# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"({%\sfor\s)([^{]|{(?!%\s(?:end)?for\s)|(?1)(?2)*(?3))*?customfield(?2)*({%\sendfor\s%})"
test_str = ("as;flkjas;dflj sa;dfkj;s afdjk \n"
"{% for some in some%}\n"
" lj;lkj;lkj;ljk\n"
"{% endfor%}\n"
"{% for pepe in pepito %}\n"
" ;aldjkf ;ajkdf;ak \n"
" jfd;kajd;fjkasd;f\n\n"
" {% for pepe in pepito %}\n"
" customfield\n"
" ;aldjkf ;ajkdf;ak \n"
" asdfsadf asdf sadf asdf asdfasd \n"
" jfd;kajd;fjkasd;f\n"
" {% endfor %}\n\n"
" customfield\n\n"
" asdfasdf\n"
" asdfasdf\n"
"{% endfor %}\n"
"sadfasdf\n"
"sadf\n"
"{% endfor %}\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.