import Foundation
let pattern = #"({%\sfor\s)([^{]|{(?!%\s(?:end)?for\s)|(?1)(?2)*(?3))*?customfield(?2)*({%\sendfor\s%})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
as;flkjas;dflj sa;dfkj;s afdjk
{% for some in some%}
lj;lkj;lkj;ljk
{% endfor%}
{% for pepe in pepito %}
;aldjkf ;ajkdf;ak
jfd;kajd;fjkasd;f
{% for pepe in pepito %}
customfield
;aldjkf ;ajkdf;ak
asdfsadf asdf sadf asdf asdfasd
jfd;kajd;fjkasd;f
{% endfor %}
customfield
asdfasdf
asdfasdf
{% endfor %}
sadfasdf
sadf
{% endfor %}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)