const regex = /({%\sfor\s)([^{]|{(?!%\s(?:end)?for\s)|(?1)(?2)*(?3))*?customfield(?2)*({%\sendfor\s%})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('({%\\sfor\\s)([^{]|{(?!%\\s(?:end)?for\\s)|(?1)(?2)*(?3))*?customfield(?2)*({%\\sendfor\\s%})', 'g')
const str = `as;flkjas;dflj sa;dfkj;s afdjk
{% for some in some%}
lj;lkj;lkj;ljk
{% endfor%}
{% for pepe in pepito %}
;aldjkf ;ajkdf;ak
jfd;kajd;fjkasd;f
{% for pepe in pepito %}
customfield
;aldjkf ;ajkdf;ak
asdfsadf asdf sadf asdf asdfasd
jfd;kajd;fjkasd;f
{% endfor %}
customfield
asdfasdf
asdfasdf
{% endfor %}
sadfasdf
sadf
{% endfor %}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}