using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"({%\sfor\s)([^{]|{(?!%\s(?:end)?for\s)|(?1)(?2)*(?3))*?customfield(?2)*({%\sendfor\s%})";
string input = @"as;flkjas;dflj sa;dfkj;s afdjk
{% for some in some%}
lj;lkj;lkj;ljk
{% endfor%}
{% for pepe in pepito %}
;aldjkf ;ajkdf;ak
jfd;kajd;fjkasd;f
{% for pepe in pepito %}
customfield
;aldjkf ;ajkdf;ak
asdfsadf asdf sadf asdf asdfasd
jfd;kajd;fjkasd;f
{% endfor %}
customfield
asdfasdf
asdfasdf
{% endfor %}
sadfasdf
sadf
{% endfor %}
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}