# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([aeiouy])(\s*)([bcdfghjklmnpqrstvwxz])/$1$2\U$3\E/gmi;t' <<< "hello world
xaabeuekadii
A quick brown fox jumps over the lazy dog"