import re
regex = re.compile(r"([aeiouy])(\s*)([bcdfghjklmnpqrstvwxz])", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("hello world\n"
"xaabeuekadii\n"
"A quick brown fox jumps over the lazy dog")
subst = "$1$2\\U$3\\E"
result = regex.sub(subst, test_str)
if result:
print(result)