// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)([aeiouy])(\s*)([bcdfghjklmnpqrstvwxz])").unwrap();
let string = "hello world
xaabeuekadii
A quick brown fox jumps over the lazy dog";
let substitution = "$1$2\\U$3\\E";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}