#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)([aeiouy])(\s*)([bcdfghjklmnpqrstvwxz])"
Local $sString = "hello world" & @CRLF & _
"xaabeuekadii" & @CRLF & _
"A quick brown fox jumps over the lazy dog"
Local $sSubst = "$1$2\U$3\E"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)