package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)([aeiouy])(\s*)([bcdfghjklmnpqrstvwxz])`)
var str = `hello world
xaabeuekadii
A quick brown fox jumps over the lazy dog`
var substitution = "$1$2\U$3\E"
fmt.Println(re.ReplaceAllString(str, substitution))
}