using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([aeiouy])(\s*)([bcdfghjklmnpqrstvwxz])";
string substitution = @"$1$2\U$3\E";
string input = @"hello world
xaabeuekadii
A quick brown fox jumps over the lazy dog";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}