#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z0-9-]+(?:_[0-9]+){2}\..+$"
Local $sString = "MATCH" & @CRLF & _
"file_123_456.txt" & @CRLF & _
"" & @CRLF & _
"DON'T MATCH" & @CRLF & _
"f?()1_dwj_weq.txt" & @CRLF & _
"file_123_456." & @CRLF & _
"file.txt" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")