re = /^[A-Za-z0-9-]+(?:_[0-9]+){2}\..+$/m
str = 'MATCH
file_123_456.txt
DON\'T MATCH
f?()1_dwj_weq.txt
file_123_456.
file.txt
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end