package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z0-9-]+(?:_[0-9]+){2}\..+$`)
var str = `MATCH
file_123_456.txt
DON'T MATCH
f?()1_dwj_weq.txt
file_123_456.
file.txt
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}