// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Za-z0-9-]+(?:_[0-9]+){2}\..+$").unwrap();
let string = "MATCH
file_123_456.txt
DON'T MATCH
f?()1_dwj_weq.txt
file_123_456.
file.txt
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}