const regex = /^[A-Za-z0-9-]+(?:_[0-9]+){2}\..+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Za-z0-9-]+(?:_[0-9]+){2}\\..+$', 'gm')
const str = `MATCH
file_123_456.txt
DON'T MATCH
f?()1_dwj_weq.txt
file_123_456.
file.txt
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}