$re = '/^[A-Za-z0-9-]+(?:_[0-9]+){2}\..+$/m';
$str = 'MATCH
file_123_456.txt
DON\'T MATCH
f?()1_dwj_weq.txt
file_123_456.
file.txt
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);