import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z0-9-]+(?:_[0-9]+){2}\\..+$";
final String string = "MATCH\n"
+ "file_123_456.txt\n\n"
+ "DON'T MATCH\n"
+ "f?()1_dwj_weq.txt\n"
+ "file_123_456.\n"
+ "file.txt\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}