#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\w)-\s(?=\w)"
Local $sString = "the sun was shin- ing and the sky bl- ue" & @CRLF & _
"the sun was shin- ing and the sky bl- u- es" & @CRLF & _
"bl-" & @CRLF & _
"ue" & @CRLF & _
"" & @CRLF & _
"a - a , 1 - a , 1 - 1 "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)