using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\w)-\s(?=\w)";
string substitution = @"";
string input = @"the sun was shin- ing and the sky bl- ue
the sun was shin- ing and the sky bl- u- es
bl-
ue
a - a , 1 - a , 1 - 1 ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}