import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\w)-\\s(?=\\w)";
final String string = "the sun was shin- ing and the sky bl- ue\n"
+ "the sun was shin- ing and the sky bl- u- es\n"
+ "bl-\n"
+ "ue\n\n"
+ "a - a , 1 - a , 1 - 1 ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}